Hi Stephan, Wichert, Michael

> Betreff: Re: [Zope3-checkins] [Checkins] 
> SVN:zope.app.component/trunk/setup.py set missing minimum version
> On Sunday 15 March 2009, Wichert Akkerman wrote:
> > If the package does not work with an older version of 
> zope.publisher 
> > than imho that version restriction *has* to be in setup.py.
> And what if I backport the fix?
> We have done version specification like this in the Zope 
> packages before and it almost brought development to complete 
> halt, because versions would not match anymore.


If one of several packages doesn't get updated with buildout
is only possible if someone uses an index server which only
have one of the both released packages available.

If this is not true, then this is a bug in buildout
and buildout doesn't catch the package versions correct.
Which I think is not the case.

All other reason I can think about that someone only
got one package and another not if two package
get released depends on a bad package management.

Fix versions are a pain because you can't be sure that
someone uses a patched or branched package which you
will fix the version for.

Package management should never be done in a single package!

can you explain what's happen that you didn't got the 
zope.publisher release? And was this problem solved
after fixing the version or did you do something else too?

Roger Ineichen

> Regards,
> Stephan
> --
> Stephan Richter
> Web Software Design, Development and Training Google me. 
> "Zope Stephan Richter"
> _______________________________________________
> Zope3-Checkins mailing list
> zope3-check...@zope.org
> http://mail.zope.org/mailman/listinfo/zope3-checkins

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to