Martijn Faassen wrote:
> Shane Hathaway wrote:
>> - zope.app.publisher: A library of ZCML directives for configuring
>> views. Also provides generic view classes. A better name for this
>> package might be "zope.basicviews". A lot of packages depend on this.
> I'm not sure 'basic' needs to be in there. Do we have anything less basic?
> What about simply calling it zope.view? (I don't like the plural in
> package names either generally)
Sounds good to me.
>> - zope.app.publication: Provides IPublication implementations and a
>> mechanism/registry for choosing a different publication class for each
>> request. Most packages should not depend on this. A better name might
>> be "zope.publicationregistry".
> I'm fine with this. I was considering 'zope.publication', but we already
> have 'zope.publisher' so that'd get very confusing again, something we
> should avoid.
>> - zope.app.http: Provides generic views that translate HTTP verbs like
>> PUT, DELETE, and OPTIONS into map operations. The idea is clever, but
>> not everyone needs a REST-style API. A better name might be
> Even though I don't really like the plural, I think 'zope.http' would
> promise a bit too much, so 'zope.httpverbs' sound better.
Another option is "zope.rest", because a simple REST interface is what
the package tries to accomplish.
> So if we get some consensus about this, we need volunteers that can help
> move the code over to these new packages and leave backwards compatible
> imports in the old places. Is there anything in these packages we can
> safely leave behind do you think? (ZMI related, perhaps?)
I haven't come across anything we'd want to leave behind.
zope.app.publisher -> zope.view
zope.app.publication -> zope.publicationregistry
zope.app.http -> zope.rest
Zope-Dev maillist - Zope-Dev@zope.org
** No cross posts or HTML encoding! **
(Related lists -