Tres Seaver wrote:
> Philipp von Weitershausen wrote:
>>> I've long been thinking about how to make <browser:page /> simpler and
>>> less magical. Some radical ideas weren't received well and I couldn't
>>> convince even myself 100% that they were the way to go. Other
>>> brainstormings were dead ends.
>>> I therefore call this proposal a compromise. It simplifies, but it
>>> shouldn't annoy (Tres...). Note that I'm specifically only addressing
>>> <browser:page />, not <browser:view />; nor am I coming up with a
>>> framework for dealing with forms and their handlers (Jeff...).
>>> 'Nuff said. Your turn :)
> -1 on breaking ZCML in the wild. Propose *new* directives which have
> new semantics, but for existing directives, we should clean up the
> implementation rather than modifying semantics. E.g., we should be able
> to rip out the gunk which synthesizes new classes in 'browser:page': I
> think it derives from a period before we could assign a
> '__Security_checker__' attribute to instances, and so *had* to have a
> class in order to make the checker stuff work.
It's not only the security checker. It's the whole IBrowserPublisher
implementation that's jerked into the subclass. My proposal is exactly
Of course, we can implement new directives (possibly with the same name
but different namespace URI) and deprecate the old ones. But that's only
marginally different from what I propose.
Zope3-dev mailing list