On Wednesday 15 August 2007 07:41, Michael Howitz wrote:
> - ISite isn't a good name for the concept behind it, because it is
> connected too tight to a website and on having hierarchical
> structures (at least in the code).
I think this is a matter of documentation and explanation. Anyone working
longer than a week with Zope 3 knows what our extended concept for a site is.
Terms always overlap accross problem domains, this is nothing new. We need to
stop thinking that our branch of engineering/science is special and that we
have to reinvent everything.
> - In short term, for cleaning up dependencies, I propose to move
> ISite to zope.location, because it is the only package outside of of
> zope.app.* which uses ISite and defindes a method to get the nearest
> site. We think this is the right place because ISite is about
> component registries in the context of location.
After reading the first sentence, I was against it. After reading your
explanation this sounds like a good idea, so +1 from me.
CBU Physics & Chemistry (B.S.) / Tufts Physics (Ph.D. student)
Web2k - Web Software Design, Development and Training
Zope3-dev mailing list