Stephan Richter wrote:
Hello everyone,

Roger and I are proud to announce the first release of the new form and widget
framework ``z3c.form``! After years of talking about it, months of thinking
about it and many weeks of implementation, we have finally completed it.

First of all, thanks for this, very kind of you to share
your hard work.


For the curious and impatient ...
---------------------------------

To run the demos do the following::

  $ svn co svn://svn.zope.org/repos/main/z3c.formdemo/trunk formdemo
  $ cd formdemo
  $ python bootstrap.py
  $ ./bin/buildout
  $ ./bin/demo fg


I did try the above, but it complained about needing a
newer setuptools than I had.  No big deal, I can update
that easily enough.

Before I go further though, does the above command set
install a full version of zope and if so, what version?

Do I need 3.4.0a1 to run this demo or can I use 3.3.0
or 3.3.1?  I'm running 3.3.0 but can upgrade to 3.3.1.


Installation
------------

All packages have been released in source and binary-egg format on PyPI and
``download.zope.org/distribution``. You can use setuptools to install
them. Here is a list of all packages:

* z3c.form
* z3c.formui
* z3c.formdemo
* jquery.javascript
* jquery.layer
* jquery.widget

So, perhaps I can install those packages (in instance/lib/python)
and I should be good to go?



Enjoy!

Regards,
Roger and Stephan

Thanks again!
Vinny
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to