Thanks, I feel like an idiot - running it as a daemon would explain why I wasn't getting as much feedback. I still don't quite get why it wasn't writing to the log though, since it is normally doing that fine. I've had that frustration with Zope before though - some errors seem to kill it in such a way it never touches the log file, even when set to all.

Shane responded, so I'll see if it is an obvious Ape problem with roles on root, and then either follow-up here with a solution/more info, in case it helps someone else, or hoping for more help, if not. Well I'll throw the trace in here, in case anyone has any bright ideas, but not expect anybody to put to much thought in until we see what he has to say. ;)



------
2005-05-25T01:25:06 INFO(0) ZServer HTTP server started at Wed May 25 01:25:06 2005
       Hostname: gibson
       Port: 9280
------
2005-05-25T01:25:06 INFO(0) ZServer FTP server started at Wed May 25 01:25:06 2005
       Hostname: gibson
       Port: 9221
------
2005-05-25T01:25:06 INFO(0) Zope Set effective user to "zope-is"
------
2005-05-25T01:25:08 DEBUG(-200) ApeStorage create storage ApeStorage: /var/lib/zope/zope-is/spicerack/var/root/
Traceback (most recent call last):
 File "/usr/lib/zope-2.7.2/lib/python/Zope/Startup/run.py", line 50, in ?
   run()
 File "/usr/lib/zope-2.7.2/lib/python/Zope/Startup/run.py", line 19, in run
   start_zope(opts.configroot)
File "/usr/lib/zope-2.7.2/lib/python/Zope/Startup/__init__.py", line 51, in start_zope
   starter.startZope()
File "/usr/lib/zope-2.7.2/lib/python/Zope/Startup/__init__.py", line 230, in startZope
   Zope.startup()
File "/usr/lib/zope-2.7.2/lib/python/Zope/__init__.py", line 47, in startup
   _startup()
File "/usr/lib/zope-2.7.2/lib/python/Zope/App/startup.py", line 96, in startup
   OFS.Application.initialize(application)
File "/usr/lib/zope-2.7.2/lib/python/OFS/Application.py", line 278, in initialize
   initializer.initialize()
File "/usr/lib/zope-2.7.2/lib/python/OFS/Application.py", line 301, in initialize
   self.install_required_roles()
File "/usr/lib/zope-2.7.2/lib/python/OFS/Application.py", line 457, in install_required_roles
   app.__ac_roles__=app.__ac_roles__ + ('Owner',)
TypeError: can only concatenate list (not "tuple") to list

Thanks,
Tim



Tim

Dennis Allison wrote:

Tim,
You may want to run Zope in debug mode-- bin/runzope should do it.
Also, be sure you have the event.log configured and enable. -d

On Wed, 25 May 2005, Tim Connor wrote:

I sent roughly this email directly to Shane Hathaway, since I hadn't asked for any help on Zope, yet, so didn't know where to look. Maybe this was a better avenue? If you read this list, Shane (or Mr. Hathaway, if you prefer), respond on whichever seems more appropriate, I guess. I don't know, let me know if I'm missing some etiquette point.

Anyways, I'm using Ape 1.0 set-up in the root of Zope 2.7.2 install, based on the example fs config, and that is working fine. I was having a problem where some change was making that Zope instance not even get far enough in booting to write to the event.log (set to level all). I narrowed it down to adding a local role on the security tab of the root object. I revert the .properties file and restart - it works. I make the change again and restart - it doesn't. I diff the file, and the only difference is the define-role line. The problem is I have no idea where to start even, since no errors are thrown where I know to find them. Zope just doesn't respond at all when I try to restart it, and writes nothing to the log.

If anyone could tell me what I can do to at least track down the problem, if not fix it, it would be much appreciated.

Thanks,
Tim
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )



_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to