On 16 Oct 2005, at 19:54, Dennis Allison wrote:
Why does Zope lag the release of Python by so very long?

Because someone has to spend considerable time to assess impacts on the Zope 2 security machinery. This has been mentioned on this and other Zope lists on various occasions.

My understanding is that the reason the Python 2.4.X is not the
recommended Python is because a "security audit" has not been performed
and not because of functionality issues.    We have been using Python
2.4.1 in production without apparent problems; I am about to move to
2.4.2 which fixes some bugs we have not encountered.

The fact that it "seems to work" is a pretty weak argument. It's like driving with really old tires where the rubber is starting to crack. It could lead to sudden failure, even though the car seems to drive just fine today.


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to