> 
> 
> > 2. The parameters $testSetPrefixes and $testCasePrefixes of driver:run() and
> > driver:fots-run() have misleading names. They don't hold prefixes anymore
> but
> > full test-set and test-case names. Can you rename to just $testSets and
> > $testCases?
> $testSetPrefixes is a prefix:
> Did you try running the CLI with something like:
> [...] -e mode:=run-test-sets -e testSetPrefixes:=prod
> This will run all test sets that have a name starting with "prod"

Yes, at the CLI level $testSetPrefixes is indeed a list of prefixes. But I am 
complaining about the $testSetPrefixes parameter of the driver:run() and 
driver:fots-run() functions. What I understand is the driver:run() treats 
$testSetPrefixes as a list of names: see the call to functx:value-intersect() 
at line 238 in fots-driver.xq. 

And there is in fact a bug here: in cli.xq the first call to driver:fots-run() 
converts the $testSetPrefixes to test-set names by calling d:list-test-sets(). 
This is correct. But the 2nd call to driver:fots-run() passes $testSetPrefixes 
directly. This is incorrect.


-- 
https://code.launchpad.net/~zorba-coders/zorba/fots_driver/+merge/133988
Your team Zorba Coders is subscribed to branch lp:zorba.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to     : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp

Reply via email to