I wrote:
> Is it enough to edit that line, make it look like

> #ifndef HAVE_COURIER
>    #define HAVE_COURIER
> #endif
> and configure/make/install?

I answer myself: no it isn't, because I've tried and that leads to a 
compile error. Then I've also tried just commenting out the #undef, 
building, installing, making it SUID root, configuring Courier to use 
that maildrop as DEFAULTDELIVERY, but still the messages are not 
actually being delivered into the virtual accounts maildirs, despite the 
logs not reporting any problem.

Sam Varshavchik writes:
 > look in the .mailfilter file

The virtual account I'm testing with has no .mailfilter.
I've tried a few things in the default /etc/maildroprc:

DEFAULT="$HOME/Maildir" # leads to message not being delivered

DEFAULT=./Maildir # same as above

DEFAULT=./Maildir/ # maildrop: Unable to open mailbox.

# empty file # maildrop: Unable to open mailbox.

logfile "/var/log/maildrop.log" # Unable to create log file.

During all these tests Courier was using my custom setuid maildrop.

Sam Varshavchik writes:
 > maildrop also has a verbose flag, that causes it to generate its own
 > logging.

but the maildrop manpage reports:

"-V is ignored when maildrop runs in delivery mode."

and maildropfilter manpage reports the same about the VERBOSE variable.

is there any other switch to make maildrop log informations while in 
delivery mode?

Please advice, I'm at a loss.

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
courier-users mailing list
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users

Reply via email to