> thanks for finding that ... guess when porting all these thousands of 
> statements, I must have missed one or two "replace: ' == ' with 
> ').isEqualTo('” __

Yep I can imaging my brain zoning out when doing that :-)

> Well the main reason was probably, that I wanted to replace the 
> "assertTrue(A==B)" with something like "assertEqual(A, B)" as this outputs 
> the "expected" and the actual "value" and hereby provides a little more 
> information than a simple "was false". So I had the option of converting it 
> to JUint "Assert.assertEquals" or update it to AssertJ's 
> "Assertions.assertThat().isEqualTo()" which I think is a little more readable

You know that Junit4 also has a assertThat? It’s has a slightly different 
signature which what threw me when I first looked at the changes.


Reply via email to