Hi Carlos,

You will just have to debug it on your end.  I would recommend:

-Verify that the source changes I made to royale-compiler are in your
local working copy.
-manually clear your local maven repo of org.apache.royale.compiler
-rebuild royale-compiler.
-Scan the console output from the royals-compiler build for undetected
errors.  Our Maven integration isn't perfect so there is a chance the
compilation could report an error that doesn't return a failure code that
stops the Maven build.
-Rebuild your example.
-Scan the console output for undetected errors. Also verify that Maven
pulled the compiler from your local repo instead of the snapshot server or
some other server.

If none of that helps you find the problem, the next thing I would do is
add a System.out.println to the code I modified so you can see if that
code gets run or not.


On 2/19/18, 11:10 AM, "carlos.rov...@gmail.com on behalf of Carlos Rovira"
<carlos.rov...@gmail.com on behalf of carlosrov...@apache.org> wrote:

>Hi Alex,
>2018-02-19 18:06 GMT+01:00 Alex Harui <aha...@adobe.com.invalid>:
>> I just tried it with Maven and it worked.  I didn't run the example, I
>> just opened App.css and saw that the contents of TextField.css are in
>> there.
>Hi Alex, I'm not seeing what you see :?
>I opened App.css in target, js-debug and Textfield is empty Only see {}
>I updated all repos and rebuild all with maven to ensure I'm with the
>> For some reason, there were some puzzling results on merging in your
>> changes.  It wanted me to push commits you had made.  Not sure why or if
>> that would affect your results.
>Right, I made a rebase but it works bad and try to fix it. The problem was
>that SourceTree had "Allow force push" unchecked.
>Could you confirm your changes are all ok?
>don't know what's hapening...
>> HTH,
>> -Alex
>> On 2/19/18, 8:29 AM, "Alex Harui" <aha...@adobe.com.INVALID> wrote:
>> >I saw it work.  But I was using the Ant build in order to test it since
>> >nobody had provided it yet.  I will try with Maven later.
>> >
>> >-Alex
>> >
>> >On 2/19/18, 6:55 AM, "carlos.rov...@gmail.com on behalf of Carlos
>> ><carlos.rov...@gmail.com on behalf of carlosrov...@apache.org> wrote:
>> >
>> >>Hi Alex,
>> >>
>> >>2018-02-19 7:08 GMT+01:00 Alex Harui <aha...@adobe.com.invalid>:
>> >>
>> >>>   But I saw that it could be easily added so I got it working
>> >>> and pushed compiler changes to a feature/vivid branch in
>> >>>royale-compiler.
>> >>>
>> >>>
>> >>This means that you get it working? after solve some repo errors, I
>> >>the three projects but I get the same result as yesterday.
>> >>Don't know if I'm doing something wrong, or I'm interpreting the email
>> >>incorrectly
>> >>
>> >>thanks
>> >>
>> >>
>> >>--
>> >>Carlos Rovira
>> >>https://na01.safelinks.protection.outlook.com/?url=http%
>> 3A%2F%2Fabout.me%
>> >>2
>> >>Fcarlosrovira&data=02%7C01%7Caharui%40adobe.com%7C2bee894a
>> 391f4de0984c08d
>> >>5
>> >>77a8de96%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C6365
>> 46489524364497&
>> >>s
>> >>data=FI%2B2hRup%2ByKMqR0qY0YYeRgt9aBDwTuHEqjSmXmonJw%3D&reserved=0
>> >
>> --
>> Carlos Rovira

Reply via email to