Hi Alex,

Don't know if you see the Piotr test of this branch. He's getting the same
as me. So my bet is that something is going on on your side that's not
happening for the rest of us. In out case the TextField selector is
completely empty.

2018-02-21 5:20 GMT+01:00 Alex Harui <aha...@adobe.com.invalid>:

> Hi Carlos,
>
> It is unlikely that Ant artifacts will affect Maven results.  They have
> different jar names.
>
> I synced up and clean my local repo and rebuilt the compiler with the
> feature/vivid branch and royale-asjs with the vivid-ui-set branch and
> everything works as expected.  In
> examples/royale/VividExample/target/javascript/bin/js-debug/App.css is a
> TextField selector that has several properties.
>
> The file I changed in royale-compiler is CSSManager.java.  Add a
> System.out.println("This is Carlos's local copy"); at the beginning of
> getCSSFromThemes.  Delete the compiler jars from your local repo and
> rebuild the compiler then the framework and example.  You should see your
> println in the output.  If you don't then for some reason you are pulling
> the wrong one.  The console output for the compiler should show that it
> put the jars in the local repo.  The console output for framework and/or
> examples should show where it got the compiler jars.
>
> -Alex
>
> On 2/20/18, 12:13 PM, "carlos.rov...@gmail.com on behalf of Carlos Rovira"
> <carlos.rov...@gmail.com on behalf of carlosrov...@apache.org> wrote:
>
> >Hi Alex,
> >
> >I removed all my maven repo and build all again. As well check that your
> >commits are in, and removed all targets to start from a clean point.
> >I created a new branch "vivid-ui-set" since the other one had the rebase
> >problem.
> >When I build Vivid, then BlueTheme and the Example I find that TextField
> >css tule is empty and sub rules for label and input are empty as well
> >I see TextField.css is in theme SWC but is not applied in final example
> >app
> >
> >I think you should get the same if you build with maven and maybe as you
> >first started to build with ANT and then with MAVEN maybe the old ant
> >content was affecting the build
> >
> >Can you take a look?
> >
> >* Check the new branch and that your changes are there
> >* remove as I did targets and royale vivid projects in .m2 repo
> >* and try to build from scratch only with maven
> >
> >If you get it to work, I think something is wrong in royale since we
> >should
> >get the same output.
> >maybe different maven version? (I'm using 3.5.0)
> >
> >Hope we can reach what's going on since I'm stuck with this problem and
> >would like to continue working on this
> >
> >Thanks in advance!
> >
> >Carlos
> >
> >
> >
> >
> >2018-02-20 0:55 GMT+01:00 Alex Harui <aha...@adobe.com.invalid>:
> >
> >> Hi Carlos,
> >>
> >> You will just have to debug it on your end.  I would recommend:
> >>
> >> -Verify that the source changes I made to royale-compiler are in your
> >> local working copy.
> >> -manually clear your local maven repo of org.apache.royale.compiler
> >> artifacts
> >> -rebuild royale-compiler.
> >> -Scan the console output from the royals-compiler build for undetected
> >> errors.  Our Maven integration isn't perfect so there is a chance the
> >> compilation could report an error that doesn't return a failure code
> >>that
> >> stops the Maven build.
> >> -Rebuild your example.
> >> -Scan the console output for undetected errors. Also verify that Maven
> >> pulled the compiler from your local repo instead of the snapshot server
> >>or
> >> some other server.
> >>
> >> If none of that helps you find the problem, the next thing I would do is
> >> add a System.out.println to the code I modified so you can see if that
> >> code gets run or not.
> >>
> >> HTH,
> >> -Alex
> >>
> >> On 2/19/18, 11:10 AM, "carlos.rov...@gmail.com on behalf of Carlos
> >>Rovira"
> >> <carlos.rov...@gmail.com on behalf of carlosrov...@apache.org> wrote:
> >>
> >> >Hi Alex,
> >> >
> >> >2018-02-19 18:06 GMT+01:00 Alex Harui <aha...@adobe.com.invalid>:
> >> >
> >> >> I just tried it with Maven and it worked.  I didn't run the example,
> >>I
> >> >> just opened App.css and saw that the contents of TextField.css are in
> >> >> there.
> >> >>
> >> >
> >> >Hi Alex, I'm not seeing what you see :?
> >> >I opened App.css in target, js-debug and Textfield is empty Only see {}
> >> >I updated all repos and rebuild all with maven to ensure I'm with the
> >> >latest
> >> >
> >> >
> >> >>
> >> >> For some reason, there were some puzzling results on merging in your
> >> >> changes.  It wanted me to push commits you had made.  Not sure why
> >>or if
> >> >> that would affect your results.
> >> >>
> >> >
> >> >Right, I made a rebase but it works bad and try to fix it. The problem
> >>was
> >> >that SourceTree had "Allow force push" unchecked.
> >> >Could you confirm your changes are all ok?
> >> >
> >> >don't know what's hapening...
> >> >
> >> >Thanks
> >> >
> >> >
> >> >
> >> >>
> >> >> HTH,
> >> >> -Alex
> >> >>
> >> >> On 2/19/18, 8:29 AM, "Alex Harui" <aha...@adobe.com.INVALID> wrote:
> >> >>
> >> >> >I saw it work.  But I was using the Ant build in order to test it
> >>since
> >> >> >nobody had provided it yet.  I will try with Maven later.
> >> >> >
> >> >> >-Alex
> >> >> >
> >> >> >On 2/19/18, 6:55 AM, "carlos.rov...@gmail.com on behalf of Carlos
> >> >>Rovira"
> >> >> ><carlos.rov...@gmail.com on behalf of carlosrov...@apache.org>
> >>wrote:
> >> >> >
> >> >> >>Hi Alex,
> >> >> >>
> >> >> >>2018-02-19 7:08 GMT+01:00 Alex Harui <aha...@adobe.com.invalid>:
> >> >> >>
> >> >> >>>   But I saw that it could be easily added so I got it working
> >> >> >>> and pushed compiler changes to a feature/vivid branch in
> >> >> >>>royale-compiler.
> >> >> >>>
> >> >> >>>
> >> >> >>This means that you get it working? after solve some repo errors, I
> >> >>build
> >> >> >>the three projects but I get the same result as yesterday.
> >> >> >>Don't know if I'm doing something wrong, or I'm interpreting the
> >>email
> >> >> >>incorrectly
> >> >> >>
> >> >> >>thanks
> >> >> >>
> >> >> >>
> >> >> >>--
> >> >> >>Carlos Rovira
> >> >> >>https://na01.safelinks.protection.outlook.com/?url=http%
> >> >> 3A%2F%2Fabout.me%
> >> >> >>2
> >> >> >>Fcarlosrovira&data=02%7C01%7Caharui%40adobe.com%7C2bee894a
> >> >> 391f4de0984c08d
> >> >> >>5
> >> >> >>77a8de96%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C6365
> >> >> 46489524364497&
> >> >> >>s
> >> >> >>data=FI%2B2hRup%2ByKMqR0qY0YYeRgt9aBDwTuHEqjSmXmonJw%3D&reserved=0
> >> >> >
> >> >>
> >> >> --
> >> >> Carlos Rovira
> >> >>
> >> >>https://na01.safelinks.protection.outlook.com/?url=
> >> http%3A%2F%2Fabout.me%
> >> >>2Fcarlosrovira&data=02%7C01%7Caharui%40adobe.com%
> >> 7C639922befb1342faa8cd08
> >> >>d577cc7b26%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%
> >> 7C63654664248598988
> >> >>7&sdata=ZacvC4KrbdzDQZoUBE5msgmqpEENookbxNGlVVoBHBo%3D&reserved=0
> >> >>
> >> >>
> >> >>
> >>
> >>
> >
> >
> >--
> >Carlos Rovira
> >https://na01.safelinks.protection.outlook.com/?url=
> http%3A%2F%2Fabout.me%2
> >Fcarlosrovira&data=02%7C01%7Caharui%40adobe.com%
> 7C421d556ef2324f8401d208d5
> >789e6fa1%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%
> 7C636547544242920441&s
> >data=Zsm8rDjQVxvhtvZyz6drm8gTJPi02arOCJlsiV3Z%2B4A%3D&reserved=0
>
>


-- 

<http://www.codeoscopic.com>

Carlos Rovira

Director General

M: +34 607 22 60 05

http://www.codeoscopic.com


Conócenos en 1 minuto! <https://avant2.es/#video>


Este mensaje se dirige exclusivamente a su destinatario y puede contener
información privilegiada o confidencial. Si ha recibido este mensaje por
error, le rogamos que nos lo comunique inmediatamente por esta misma vía y
proceda a su destrucción.

De la vigente Ley Orgánica de Protección de Datos (15/1999), le comunicamos
que sus datos forman parte de un fichero cuyo responsable es CODEOSCOPIC
S.A. La finalidad de dicho tratamiento es facilitar la prestación del
servicio o información solicitados, teniendo usted derecho de acceso,
rectificación, cancelación y oposición de sus datos dirigiéndose a nuestras
oficinas c/ Paseo de la Habana 9-11, 28036, Madrid con la documentación
necesaria.

Reply via email to