>I see the point to distinguish between "highlevel configuration API" and
>"lowlevel resource API" but even highlevel API is build around resources
>everything in Sling). Maybe there is another way/name to make the
>The "context-aware config" name still sounds too bulky to me but YMMV.
>1.) o.a.s.configuration (it will become *THE* way to do configuration in
>Sling/AEM besides *OSGi* configurations)
>2.) o.a.s.resource.configuration (it's build around resources, how to diff
>from high has to be solved)
@oliver: can you also live with carstens proposal:
this makes sense to me and gives the dot between contextaware and config a
your point seems to be mainly getting rid of the "contextaware" part, but this
is what's all about.
otherwise we have to restart the whole naming process again, but i think it's
not worth the effort.