ok, let's take o.a.s.caconfig - it's short and still unique
>From: Georg Henzler [mailto:ghenz...@apache.org]
>Sent: Friday, October 14, 2016 10:55 PM
>Subject: Re: [context-aware config] java package name
>> just removing the ".".
>+1 for removing the dot (if it was to be kept, at least it would have to
>be "o.a.s.config.contextaware" instead of "o.a.s.contextaware.config" to
>be a meaningful hierarchy).
>regarding d) other proposals:
>As o.a.s.contextawareconfig gets fairly long, using the brief
>"o.a.s.caconfig" could be better. Although a little bit cryptic at
>first, it still clearly shows that it is about a configuration mechanism
>and people will quickly get used to what "ca" means. Also "caconfig"
>will be fairly unique when googling it.