On Friday 14 October 2016 14:20:06 Stefan Seifert wrote:
> >I see the point to distinguish between "highlevel configuration API" and
> >"lowlevel resource API" but even highlevel API is build around resources
> >(as
> >everything in Sling). Maybe there is another way/name to make the
> >difference
> >obvious.
> >
> >The "context-aware config" name still sounds too bulky to me but YMMV.
> >
> >1.) o.a.s.configuration (it will become *THE* way to do configuration in
> >Sling/AEM besides *OSGi* configurations)
> >
> >2.) o.a.s.resource.configuration (it's build around resources, how to diff
> >low
> >from high has to be solved)
> >
> >3.) o.a.s.contextawareconfig
> @oliver: can you also live with carstens proposal:
> o.a.s.contextaware.config, o.a.s.contextaware.resource,
> o.a.s.contextaware.config.annotation
> this makes sense to me and gives the dot between contextaware and config a
> meaning.
> your point seems to be mainly getting rid of the "contextaware" part, but
> this is what's all about. otherwise we have to restart the whole naming
> process again, but i think it's not worth the effort.

Having an adjective as root package is rather strange and I'm not aware of one 
at Sling. If we really want to have context aware[1] in the package name I'm 
in favor of o.a.s.contextawareconfig.


[1] https://en.wikipedia.org/wiki/Context_awareness

> stefan

Reply via email to