in [1] oliver mentioned that the current java package name is not 
consistent/not ideal.

currently wie use
o.a.s.contextaware.config  => "highlevel configuration API"
o.a.s.contextaware.config.resource  => "lowlevel resource API"

bertrand and myself noted that the package name should included "contextaware" 
somewhere, using only is too generic/misleading.

so, what should we use?

a) keep o.a.s.contextaware.config + o.a.s.contextaware.config.resource

b) switch to o.a.s.contextawareconfig + o.a.s.contextawareconfig.resource to 
get rid of the additional dot that is a bit inconsistent

c) switch to o.a.s.configuration + o.a.s.configuration.resource which is 
misleading as it applies only to context-aware config

d) other proposals?

i hope we find a consensus in the next hours... or we just stick with a)



Reply via email to