>Having an adjective as root package is rather strange and I'm not aware of
>at Sling. If we really want to have context aware[1] in the package name
>in favor of o.a.s.contextawareconfig.

than it would be

o.a.s.contextawareconfig  => "highlevel configuration API"
o.a.s.contextawareconfig.resource  => "lowlevel resource API"
o.a.s.contextawareconfig.annotation => java annotations

just removing the ".".


Reply via email to