Github user chtyim commented on a diff in the pull request:
    --- Diff: 
    @@ -98,17 +109,23 @@ public Integer apply(BitSet input) {
       private final Condition containerChange;
       private final ZKClient zkClient;
       private final Multimap<String, ContainerInfo> containerStats;
    +  private final Location applicationLocation;
    +  private final List<String> allRunnableNames;
    -  RunningContainers(String appId, TwillRunResources appMasterResources, 
ZKClient zookeeperClient) {
    +  RunningContainers(String appId, TwillRunResources appMasterResources, 
ZKClient zookeeperClient,
    +                    Map<String, Map<String, LogEntry.Level>> logLevels, 
Location appLocation,
    +                    List<String> allRunnables) {
         containers = HashBasedTable.create();
         runnableInstances = Maps.newHashMap();
         completedContainerCount = Maps.newHashMap();
         startSequence = Lists.newLinkedList();
         containerLock = new ReentrantLock();
         containerChange = containerLock.newCondition();
    -    resourceReport = new DefaultResourceReport(appId, appMasterResources);
    +    resourceReport = new DefaultResourceReport(appId, appMasterResources, 
         zkClient = zookeeperClient;
         containerStats = HashMultimap.create();
    +    applicationLocation = appLocation;
    +    allRunnableNames = allRunnables;
    --- End diff --
    Better have the argument and the field named the same for clarity.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

Reply via email to