Can we have both OpenSSL 1.0.x and 1.1.x supported when configured with
-openssl-runtime and choose 1.0 or 1.1 with -openssl-linked? Anyhow?
2018-02-13 14:13 GMT+03:00 Konstantin Tokarev <annu...@yandex.ru>:
> 13.02.2018, 14:09, "Edward Welbourne" <edward.welbou...@qt.io>:
> > On Friday, 9 February 2018 10:04:30 PST Giuseppe D'Angelo wrote:
> >> The point isn't which version of Qt comes with the distribution, but
> >> binary builds. Given people do use binary builds (to have an up-to-date
> >> Qt) but not mess with OpenSSL, the outcome will be that SSL will not be
> >> functional for the users of the distributions I mentioned before.
> > Well, conversely, those who use our binary distributions on more modern
> > releases of those distributions have the opposite problem; when
> > Debian/testing upgraded to OpenSSL 1.1, it gave me problems, obliging me
> > to downgrade OpenSSL in order to continue using Qt.
> AFAIU you should install libssl1.0.2 package instead of downgrading
> AFAIK all good binary distros provide packages for parallel openssl
> when they are not binary compatible
> However, implementing QTBUG-65922 would certainly make life easier for
> some folks.
> > If folk are willing to upgrade Qt on an old distro, I don't think it's
> > any more unreasonable to ask for a new OpenSSL version than to ask folk
> > using up-to-date distros to downgrade their OpenSSL to accommodate a Qt
> > that's contemporary with the up-to-date rest of their distribution. If
> > anything, expecting the latter is more unreasonable than expecting the
> > former.
> > Eddy.
> > _______________________________________________
> > Development mailing list
> > Development@qt-project.org
> > http://lists.qt-project.org/mailman/listinfo/development
> Development mailing list
Development mailing list