I have had some people upgrading to 1.1 and asking us why it doesn’t work, so 
we have told them to downgrade explaining why. I think it is the right thing to 
do with the upgrade to 1.1, but I just want to try and prevent people 
overwriting their existing version if they are using older versions of Qt still 
so it doesn’t get in the way of that. They just need to make sure they install 
OpenSSL 1.1 to a different location then.

Andy

Fra: Timur Pocheptsov <timur.pochept...@qt.io>
Dato: fredag 9. februar 2018 09.42
Til: Andy Shaw <andy.s...@qt.io>, Moore Richard <r...@kde.org>, 
"development@qt-project.org" <development@qt-project.org>
Emne: Re: [Development] Suggestion: switch binary builds to OpenSSL 1.1 in Qt 
5.11


Andy, do you have any feedback from our customers about this? My anecdotal 
evidence so far - I have 0 bug-reports complaining they see a message: 
"Incompatible version of OpenSSL" (qsslsocket_openssl_symbols.cpp, line 1025), 
this means for me people using our binaries mostly have OpenSSL version below 
1.1.



Best regards,

    Timur.

________________________________
From: Development <development-bounces+timur.pocheptsov=qt...@qt-project.org> 
on behalf of Andy Shaw <andy.s...@qt.io>
Sent: Friday, February 9, 2018 7:44:01 AM
To: Richard Moore; development@qt-project.org
Subject: Re: [Development] Suggestion: switch binary builds to OpenSSL 1.1 in 
Qt 5.11


+ 1 from me too.



Is it clear enough from the docs for 5.9  and 5.10 that it does not support 
OpenSSL 1.1? In case someone still uses that and ends  up replacing their 
existing installation of OpenSSL without realizing.



Andy



Fra: Development <development-bounces+andy.shaw=qt...@qt-project.org> på vegne 
av Moore Richard <r...@kde.org>
Dato: torsdag 8. februar 2018 21.48
Til: "development@qt-project.org" <development@qt-project.org>
Emne: Re: [Development] Suggestion: switch binary builds to OpenSSL 1.1 in Qt 
5.11







On 8 February 2018 at 18:45, Thiago Macieira 
<thiago.macie...@intel.com<mailto:thiago.macie...@intel.com>> wrote:

As $SUBJECT says.

Only for 5.11 onward, so shouldn't affect the 5.6 and 5.9 LTS (which don't
have OpenSSL 1.1 support anyway) or any 5.10.x releases still to come.

As a bonus side-effect, users who hadn't realised they have an old, not-up-to-
date OpenSSL will have to fix the issue.





​

+1 those who need to use an older version will still be able to build their 
own. We really need to start actively pushing people to 1.1.



Cheers



Rich.


_______________________________________________
Development mailing list
Development@qt-project.org
http://lists.qt-project.org/mailman/listinfo/development

Reply via email to