On 1/26/14, 3:59 PM, Andrew Edwards wrote:

Jordi, I need you to explain this. You wrote the scripts for the pkg
installers right? What happens when you pass a version number containing
a "-" to dmd_rpm.sh? I'll tell you:

     Building for target platforms: i386
     Building for target i386
     error: line 2: Illegal character '-' in: Version: 2.065.0-b2

I initially changed the naming convention because of errors like these
cropping up all over your scripts. Change it to '~' and it craps out on
another one of your scrips for a different package. Multiple other

My question is, what is the proper version scheme that fits all the
systems that you are trying to make these packages for? This one
obviously does not work for at lease one of them.


It sent before finishing my thoughts. Anyway, the scheme you are lobbying for is the one being used. Just gotta figure out what to do about rpm for Suse and Fedora.

Reply via email to