On Thursday, 26 February 2015 at 08:19:30 UTC, Namespace wrote:
Figured it out. DGame wants OpenGL 3.0+ context. However it uses some functions in OpenGL 2.1 that have been depreciated. The mac OpenGL doesn't allow depreciated functions.


DGame's OpenGL code is too outdated to run on a 3.0+ GL context on mac.

Required fix: Either lower the context to 2.1 or upgrade the code to not use depreciated functions.

Ah, indeed. I use some outdated constants and opengl functions. But I believe I'm using also functions which need OpenGL 3.0. Could you try to reduce the OpenGL Version to 2.1 and test it again?

Wouldaya look at that, it works. http://cl.ly/image/0Z000U0m1i3U

I wonder what features are broken.
              • Re: ... Namespace via Digitalmars-d-announce
              • Re: ... stewarth via Digitalmars-d-announce
              • Re: ... stewarth via Digitalmars-d-announce
              • Re: ... Gan via Digitalmars-d-announce
              • Re: ... Rikki Cattermole via Digitalmars-d-announce
              • Re: ... stewarth via Digitalmars-d-announce
              • Re: ... Gan via Digitalmars-d-announce
              • Re: ... Gan via Digitalmars-d-announce
              • Re: ... Gan via Digitalmars-d-announce
              • Re: ... Namespace via Digitalmars-d-announce
              • Re: ... Gan via Digitalmars-d-announce
              • Re: ... Namespace via Digitalmars-d-announce
              • Re: ... stewarth via Digitalmars-d-announce
              • Re: ... John Colvin via Digitalmars-d-announce
              • Re: ... Namespace via Digitalmars-d-announce
              • Re: ... Namespace via Digitalmars-d-announce
              • Re: ... stewarth via Digitalmars-d-announce
              • Re: ... stewarth via Digitalmars-d-announce
            • Re: Dgam... Namespace via Digitalmars-d-announce
  • Re: Dgame revived Namespace via Digitalmars-d-announce

Reply via email to