On Tuesday, 4 October 2016 at 19:28:27 UTC, WebFreak001 wrote:
* detection of missing tools & installation

I'm trying to use VSCode/mac-os and getting some errors.

First, I tried to install all the required tools, and got an error because the installation/compilation couldn't find the new experimental allocators. Updating dmd fixed this, but there didn't seem to be any explicit check/message that dmd was out of date IIRC.

After updating DMD, 3 of the tools seemed to have installed correctly, but I am still getting this error:

"workspace-d is not installed or points to a folder"

I tried setting "d.workspacedPath" in user settings to the executable in the /Users/me/.vscode/extensions/... folder, but it still doesn't work.

Also, unrelated to the above, I've set"d.stdlibPath" to the appropriate paths, but completion still doesn't work. I'm guessing workspace-d not being found has something to do with this..?

Anyways, thanks for the good work. Can't wait to get this thing up and running.

Reply via email to