Does the "remote" option
  http://www.mozilla.org/unix/remote.html  (which may be somewhat out of date)
exist on windows ?
If firefox is also running on the local machine, could a remote connection be attempted over Citrix ? I have seen such things on Linux (without Citrix).


Starting firefox with "-no-remote" may disable this complication ...



On Tue, 13 Feb 2018, Keith Graber wrote:

Hi Jim,

The issue happens with both RDP and ICA sessions.  When logged into the console 
the pages display without issue.

Keith


From: Jim Mathies [mailto:jmath...@mozilla.com]
Sent: Tuesday, February 13, 2018 9:06 AM
To: Keith Graber <keith.gra...@lsssd.org>
Cc: enterprise@mozilla.org
Subject: RE: [Mozilla Enterprise] Firefox + Citrix = No display of pages; but.. 
it's clearly 'working'.

Hey Keith,

When this happens, you're accessing the device running Firefox remotely 
correct? Either through a service like Citrix, or RDP? Or is 64-bit Firefox 
simply not working on your Server 2008 R2 device?

Regards,
Jim

From: Keith Graber [mailto:keith.gra...@lsssd.org]
Sent: Tuesday, February 13, 2018 8:14 AM
To: Jim Mathies <jmath...@mozilla.com<mailto:jmath...@mozilla.com>>; 
enterprise@mozilla.org<mailto:enterprise@mozilla.org>
Subject: RE: [Mozilla Enterprise] Firefox + Citrix = No display of pages; but.. 
it's clearly 'working'.

Jim

FYI - the pages not displaying issue happens even without an active ICA 
(Citrix) connection.

I had the same issue installing FF v58.02 x64 on Server 2008 R2.  Once I 
installed FF v58.02 x86 the pages were displayed correctly (ICA, RDP and 
console).  From my research this has been an issue since FF v58 was released, 
and v58.01 was to fix a security issue and this display issue specify.

Keith


From: Enterprise [mailto:enterprise-boun...@mozilla.org] On Behalf Of Jim 
Mathies
Sent: Tuesday, February 13, 2018 8:04 AM
To: enterprise@mozilla.org<mailto:enterprise@mozilla.org>
Subject: Re: [Mozilla Enterprise] Firefox + Citrix = No display of pages; but.. 
it's clearly 'working'.

I was just looking over this Citrix Receiver product, and I have to be honest, 
I'm not sure what service it's offering. Can you explain a bit more what you're 
using this for?

FYI I filed a bug on this for investigation -
Bug 1437863<https://bugzilla.mozilla.org/show_bug.cgi?id=1437863> - No content 
displayed in 64-bit Firefox with Citrix Receiver

Regards,
Jim Mathies


From: Enterprise [mailto:enterprise-boun...@mozilla.org] On Behalf Of Jeremy 
Moskowitz
Sent: Monday, February 12, 2018 3:01 PM
To: enterprise@mozilla.org<mailto:enterprise@mozilla.org>
Subject: [Mozilla Enterprise] Firefox + Citrix = No display of pages; but.. 
it's clearly 'working'.

FF Ent list..

Here's my lashup:


 1.  Trying to do Firefox within Citrix alongside of other browsers. FF 58.0.2. 
64-bit on Server 2016 / Citrix 7.9.
 2.  When I run Firefox from Citrix Receiver, it launches fine.
 3.  Typing items in the search bar demonstrates that pre-fetched searches / internet 
connection is working... 
https://cl.ly/3C3C1f3K2o16<https://linkprotect.cudasvc.com/url?a=https://cl.ly/3C3C1f3K2o16&c=E,1,54eHVvvIOtclS8jZPyKtjxgoOOQOfl_8-9KO69V7hvp2eIMlAMtL2LVKKsYasWnPXirZRxuD0FcJ-XdQ4z2ZO5qcKIg2Hs4d3FqqAp-Bd7Ze&typo=1>
 4.  Then clicking upon / doing directly to any URL... gets me this:  
https://cl.ly/1P2l31001I1u<https://linkprotect.cudasvc.com/url?a=https://cl.ly/1P2l31001I1u&c=E,1,Bp5L6nHbLUCDbjh1sbfeIomt6rcgWTicN7iEQxTeub7pLdISLDJoEFKdE2DnqN7cEQb7k2CqGX5_cB6e3JZqK4gnfOJ941TksWK02V23BvLfm9UZy5IV&typo=1>
 5.  Other browsers are cooporating from within Citrix Receiver client. Problem 
this moment is only FF.
 6.  Also.. Going to about:config .. same. Just nothing. Cannot access while 
using Citrix Receiver. (Works fine while ON the Citrix server.)
 7.  About:preferences.. does work.. and my thought was to turn off Hardware Acceleration.. 
which is now set like this: 
https://cl.ly/2e3a221t0A45<https://linkprotect.cudasvc.com/url?a=https://cl.ly/2e3a221t0A45&c=E,1,Ctrb_xsq6Fy2l64cc0s5cvV6lyPDzdIxLQ2pbmq33KiYfBkBgV4ey3Mhi4DmJ0TYaPq4D3x79rxp99gZnobXKt83wbdLVacO7LbqNXIZ&typo=1>
 8.  When I run Firefox from within the Citrix server itself.. All is perfectly 
perfect. All webpages load as expected.
 9.  The key takeaway though is.. The "New Tab" ... animation is going. (Super small animated 
gif / video demo: 
https://cl.ly/3F1n2G2k1z3p<https://linkprotect.cudasvc.com/url?a=https://cl.ly/3F1n2G2k1z3p&c=E,1,5lrcv_4I_v7oGQR1SVVzpH-gq3128S70vxgM-p_wLeTn-gczaVyEYcJy3nUZhWsgX9RmJmwv565qFSAbCmWUdV7YfxDoZnTYaiCDQdsPxDLbV5AjcODdqZeS_ko,&typo=1>
 ) and the page never loads.

Ideas? Thanks in advance..

--
Jeremy Moskowitz, Group Policy MVP
Founder PolicyPak Software
Home of 
GPanswers.com<https://linkprotect.cudasvc.com/url?a=https://GPanswers.com&c=E,1,gvKypTUtfT0MqbEChT6Tt9qA40GE5MT2R9410EZ-izydW_6WcRnYucE1OVwfNhERgK3wy4PGIBRZEgZDQ6-QvmKmsCfwPVn_xxPHa3QR8EJ9Yw,,&typo=1>


_______________________________________________
Enterprise mailing list
Enterprise@mozilla.org
https://mail.mozilla.org/listinfo/enterprise

To unsubscribe from this list, please visit https://mail.mozilla.org/listinfo/enterprise 
or send an email to enterprise-requ...@mozilla.org with a subject of 
"unsubscribe"

Reply via email to