Hi all.  I'm really confused by messages from people who say they're
using Evolution with MAPI support and it's working just fine for them.
I can't understand it: it's so far from working for me that there must
be something I'm doing wrong or something about my environment which is
very different from others.

As you may know, I've been using Evo with Exchange support for many
years, and helped track down (and even fixed a couple of) bugs in the
OWA backend.  I do know my way around :-).  However, about a year ago my
company switched from Exchange 2003, which worked great for me with Evo
OWA backends circa that timeframe (2.24 or so), to Exchange 2007.  Since
then I've been running lookOut! in Crossover Linux, which works but is
sucky in so many ways.  Recently I decided to try again and got my
makefile working to build newer versions of Evo from git.  My first
attempt led to my entire Exchange server Inbox being deleted without
warning when I accidentally pressed CTRL-E :-(.  After I discovered that
such a serious bug had been reported more than two releases ago but
never fixed I was put off enough to give up again.

After a couple of days off and plenty of turkey, I was mellow enough to
give it another try... but it's so fundamentally not working I'm not
sure if it's even appropriate to file bugs at this point.

Details: I'm running on Ubuntu 9.10 64bit.  I am building from the
latest git master branch, updated as of this morning, for the following
Gnome packages:
        evolution  evolution-data-server  evolution-exchange
        evolution-mapi  evolution-webcal  gtkhtml  libgweather  libsoup
        libxml2
(not in that order obviously).  Other libs/etc. are being taken from the
*-dev packages provided by Ubuntu (so they're 2.28 versions).  The
builds install everything into a separate directory (/opt/evo-master) so
there's no interference with any libraries installed in /usr on my
system.  I run Evo via a script that configures PATH, LD_LIBRARY_PATH,
PKG_CONFIG_PATH, and even BONOBO_ACTIVATION_PATH (although I don't think
that's needed any longer) to use my version.

I've tried building the latest code checked out from the Evo 2.28 git
branch, by the way, with similar results.

I'm also building and using the latest openmapi code checked out from
their SVN trunk as of this morning.  I've checked compile lines
and .deps files, etc. to verify that I'm using the proper headers, etc.

Here's what happens:

First, using this version with my personal IMAP account works fine,
modulo a few graphical glitches (not remembering window sizes, etc.)

I add a new "Evolution MAPI" account, and enter my Exchange server
address etc.  It asks me to log into the server to verify my password
and this all works fine.

After the account creation is set up, things seem fine at first glance:
I can see all my Exchange folders etc.  But it goes downhill from there.

-----
Missing Subject: content:

First, I got an error in the message bar trying to load my main Inbox
(just said error--no details).  Now I see all the messages that are in
my Inbox, but at least half of them have no Subject: shown in the
summary window.  I do see the From: address, date, even the attachment
"paper clip" is there... but no Subject.  If I click on these messages
they are displayed OK, but this doesn't add a subject to the summary
either.  New email I get seems to (small sample size) always have a
summary, so it's just retrieving historical email that's problematic I
guess.

I tried deleting ~/.evolution/mail/mapi/*/folders.db, restarting, etc.
but that didn't help; I suppose there's something else I should be
deleting to try to get Evo to reread the summary info?

-----
Bogus TNEF message attachment to all sent mail:

If I use lookOut! to send an email message to my private account, it
shows up fine as a text message.

If I use Evo MAPI to send an email message to my private account, it
shows up BUT instead of a simple quoted-printable message, it's
multipart/mixed and there's an extra application/ms-tnef attachment;
looking at the message source I see:

        --_000_0C8E40D1B3E28947A3EA5E185EF1C9B2B5366DF137MYEXCH01net_
        Content-Type: text/plain; charset="us-ascii"
        Content-Transfer-Encoding: quoted-printable
        
        one two three
        
        --_000_0C8E40D1B3E28947A3EA5E185EF1C9B2B5366DF137MYEXCH01net_
        Content-Disposition: attachment; filename="winmail.dat"
        Content-Transfer-Encoding: base64
        Content-Type: application/ms-tnef; name="winmail.dat"
        ...

The bizarre thing is when I send an email from Evo MAPI to my Exchange
account, it's fine: there's no TNEF attachment.  So, it seems like the
Exchange server is adding this attachment for me to mail that goes out
to a remote address, but only for email that comes from Evo MAPI and not
for email that comes from lookOut!... what's the difference here?

-----
No calendar available:

When I click on my calendar in Evo I see the MAPI calendar listed, but
NO appointments from that calendar appear anywhere in my calendar.  It's
completely empty.

If I try to create a meeting by selecting an hour on the calendar then
right-clicking and saying "New Meeting..." then nothing happens: no
popup, no dialog, no error message, no nothing.

-----
No address books available:

When I click on Contacts I see a section for my MAPI account, with both
"Contact" (for my personal contacts) and "Global Address Book" (for the
corporate address book.  But, no lookups in either of these work.  No
matter what I type in the search box, nothing is displayed; no errors,
no warnings, no dialogs, just nothing at all.

Also, if I click the "To:" box in a new email message I get an address
lookup dialog, but searching GAL or Contacts here also does nothing;
nothing is returned.

-----
So... not very useful :-/.  This is so far from working that I'm really
surprised to see others report that it's working well: there has to be
some difference.  How can I proceed?  I have my own versions built with
-g and with no optimization, so it's easy to debug.  I have a script I
use to start Evo that sets:

        E2K_DEBUG=5
        CAMEL_DEBUG=all
        export E2K_DEBUG CAMEL_DEBUG

and redirects all output to a log file, as well as setting unlimited
core file sizes etc. so I'm well positioned to send debug output or
whatever anyone wants to see--although hopefully there are OTHER
debugging flags that can be enabled because most of the operations above
don't even print anything to the log file.

What can I do to help?

_______________________________________________
Evolution-hackers mailing list
Evolution-hackers@gnome.org
http://mail.gnome.org/mailman/listinfo/evolution-hackers

Reply via email to