Alex Romosan wrote:
> i noticed that on the f16 the speedbrakes have no effect at all and i
> managed to track it down to the fact that the various coefficients use
> fcs/mag-speedbrake-pos-rad on input which never gets set anywhere (so
> it is always 0).
> digging through the cvs logs i found that in version 1.17 of f16.xml
> the output of fcs/speedbrake-cmd-norm used to be fcs/speedbrake-pos-rad
> and it was set to 1.05 (which would translate roughly to 60 degrees).
> so i tried applying this patch:

> now the various coefficients change when i activate the speedbrake but
> there is still no noticeable effect on the plane.
> does anybody have any ideas how to fix the speedbrakes?

Looking at the code it looks like setting speed-break-pos-norm should be 
the same as setting speed-break-pos-rad so the patch shouldn't have any 

I think you expect too much effect from the speedbrakes, they are quite 
small for the F-16 and can be deployed in-flight without any problems 
(in fact, they tend to get used during the complete final approach cycle 
over here).

Try diving without any power (throttle to nil) with the speedbrakes 
deployed for a while and then retract them. If all works well you will 
see the speed increase.


This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
Flightgear-devel mailing list

Reply via email to