Thanks a lot mike, these are mostly acceptable for me.
> Here's the latest ACPI megapatch:
> - Move all the register I/O into a separate file
> - Made all the I/O spaces use proper bus resources
> - Allocate the resources in machine-dependant code
I prefer previous patch because most of the code in i386/acpi_machdep.c
can be shared with IA64 I think.
> - Map ACPI-used memory in machine-dependant code
> - Create a machine-dependant "acpiprobe" device which just knows
> how to find and set up ACPI for the machine-independant code
I think only machine-dependant sub-routines should be in acpi_machdep.c,
the rest common code should be moved back to dev/acpi/acpi.c.
The first half of acpiprobe_identify() is trying to find rsdp, so
renaming it to acpi_find_rsdp() (returns struct ACPIrsdp * or NULL),
moving the rest of acpiprobe_identify() to dev/acpi/acpi.c:acpi_identify()
and calling acpi_find_rsdp() from acpi_identify() would be better for me.
acpiprobe_mapmem() seems machine-dependant, so just renaming (acpi_mapmem() ?)
would be enough.
acpiprobe_facp(), I think, is MI, should be moved dev/acpi/acpi.c and
renamed (acpi_find_facp() ?).
In summary, my suggestions are
acpi_find_rsdp() and acpi_mapmem()
acpi_identify() and acpi_find_facp()
> - Remove all the ACPI #ifdefs from non-ACPI code
> - Minor style and commenting fixes
> Issues outstanding:
> - Need to remove superfluous headers
> - Need to decide the correct split between <sys/acpi.h> and
> <sys/dev/acpi/acpi.h> in terms of functionality.
I'd like to move and rename them as I said in my previous mail,
<sys/acpi.h> -> <sys/dev/acpi/acpi.h>
shared by both kernel and userland programs
<sys/dev/acpi/acpi.h> -> <sys/dev/acpi/acpivar.h>
shared within kernel code (acpi stuff and related drivers)
That's my rough understanding, but I could be wrong :-)
To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message