From: Mitsuru IWASAKI <[EMAIL PROTECTED]>
Subject: [acpi-jp 691] Re: ACPI megapatch
Date: Fri, 29 Sep 2000 22:05:17 +0900
Message-ID: <[EMAIL PROTECTED]>
> > Issues outstanding:
> > - Need to remove superfluous headers
> > - Need to decide the correct split between <sys/acpi.h> and
> > <sys/dev/acpi/acpi.h> in terms of functionality.
> I'd like to move and rename them as I said in my previous mail,
> <sys/acpi.h> -> <sys/dev/acpi/acpi.h>
> shared by both kernel and userland programs
> <sys/dev/acpi/acpi.h> -> <sys/dev/acpi/acpivar.h>
> shared within kernel code (acpi stuff and related drivers)
IMHO, it's desirable to use the name "acpi.h", because of conflict
with the file dumped by /usr/sbin/config.
I love :
fooreg.h : device dependent and implementation independent
structures, macros, and others.
foovar.h : implementation dependent ones.
To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message