On Sat, Jan 11, 2003 at 11:31:22AM -0600, Jack L. Stone wrote:
> I just updated from FBSD-4.5 to 4.7 on a server running apache_fp.1.26. The
> update somehow has broken the FP extensions (ugh!). I have tried a number
> of fixes, including portupgrade, but get a checksum error there. Have tried
> to rerun the present install of FP using fp_install.sh, but get this error:
> Who should own web root web on port 80 [www]:  
> What should the group for web root web on port 80 be [www]:  
> /usr/libexec/ld-elf.so.1: /usr/lib/libm.so.2: Undefined symbol "__stderrp"
> ERROR: Unable to chown web root web in port 80
> Hit enter to continue
> I'm also seeing the "__stderrp" error in my httpd-error.log whenever I try
> to login to FP. So, something has changed in the FBSD-4.5-4.7 update and
> I've never seen this error, so don't know what needs to be fixed. I have
> another server running apache_fp.1.27 on FBSD.4.7 just fine.
> It's looking like an uninstall/reinstall completely for apache+fp....
> didn't want to have to do that on a box with a bunch of virtual hosts.....
> Has anyone seen the above problem on similar installs...???

/usr/src/UPDATING says:

        The definitions of the standard file streams (stdio, stdout, and
        stderr) have changed so that they are no longer compile-time 
        constants.  Some older binaries may require updated 3.X 
        compatability libraries (for example, by setting COMPAT3X=yes 
        for a buildworld/installworld).

Alternatively to doing a buildworld with COMPAT3X=yes, you could
install the misc/compat3x port.



Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to