On Monday 03 March 2003 06:30 pm, Roger Merritt wrote:
> At 01:15 PM 3/3/03, Kent Stewart wrote:
> >On Sunday 02 March 2003 08:55 pm, Roger Merritt wrote:
> > > At 05:15 AM 3/3/03, Kent Stewart wrote:
> > > ><snip>
> On Marcus' advice I took a look at my version of Python. Somehow I
> had version 1.6, while the port is 1.5.2_2! So I have run
> 'pkg_deinstall python 1.6' and am now running 'portupgrade -NR
> lang/python15' (it reported there was no package or port named
> "python15"). When that's done I'll try again with libxml2 and
> libxslt. And pango.

The port system is really simple and straight forward. If you change 
anything, then you have to be able to deal with it on your own. "Change 
anything" includes refusing ports, not rebuilding INDEX*, and etc. Some 
how you changed things by adding 1.6 and we all saw what happened. Now, 
we just have to remember it until the next person does it :). I am 
reasonably sure you will but many of the rest of us might not.

> But thank goodness for this mailing list. Otherwise I'd never find
> out about some of these "gotchas".

I learned something out of this too. Fontconfig was modified and so I 
tried -Rup fontconfig. Portupgrade just built fontconfig. Next I tried 
-pur fontconfig. It rebuild Xft, which had also been upgraded, and just 
repackaged everything that used them below that. Now, the kicker is 
that qt-3.x uses Xft.2 in the build but it was not rebuilt. I had to 
run -pufr fontconfig for that to happend.


Kent Stewart
Richland, WA


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to