坂本と申します。

eel が portupgrade 中に以下のエラーでアップグレードできませんでした。

checking for GNOME_DESKTOP... configure: error: Package requirements
(libxml-2.0 >= 2.4.20\
 gdk-pixbuf-2.0 >= 2.4.0 gtk+-2.0 >= 2.11.3 glib-2.0 >= 2.15.4 gio-2.0
>= 2.15.4 libgnomeu\
i-2.0 >= 2.6.0 gconf-2.0 >= 2.0.0 libstartup-notification-1.0) were
not met:

Package pangocairo was not found in the pkg-config search path.
Perhaps you should add the directory containing `pangocairo.pc'
to the PKG_CONFIG_PATH environment variable
Package 'pangocairo', required by 'GDK', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables
GNOME_DESKTOP_CFLAGS
and GNOME_DESKTOP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

===>  Script "configure" failed unexpectedly.
** Command failed [exit code 1]: /usr/bin/script -qa
/tmp/portupgrade.12304.0 env UPGRADE_\
TOOL=portupgrade UPGRADE_PORT=eel-2.22.2_1 UPGRADE_PORT_VER=2.22.2_1
make
** Fix the problem and try again.
--->  Build of x11-toolkits/eel ended at: Sun, 11 Jan 2009 19:35:48
+0900 (consumed 00:00:\
36)
--->  Saving the log as '/var/log/ports/x11-toolkits::eel'
--->  Upgrade of x11-toolkits/eel ended at: Sun, 11 Jan 2009 19:35:48
+0900 (consumed 00:0\
0:36)
--->  ** Upgrade tasks 1: 0 done, 0 ignored, 0 skipped and 1 failed
--->  Listing the results (+:done / -:ignored / *:skipped / !:failed)
        ! x11-toolkits/eel (eel-2.22.2_1)       (configure error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
--->  Session ended at: Sun, 11 Jan 2009 19:35:48 +0900 (consumed
00:00:39)

Makefile に PKG_CONFIG_PATH=/usr/local/bin/ と書いてみたのですが、同じ
エラーでアップグレードできません。

対処法があるでしょうか。

--
SAKAMOTO Makio

メールによる返信