--On 31 July 2015 16:17 +0200 Roger Pau Monné <roger....@citrix.com> wrote:

This is a bug then. You should be able to boot without XENHVM/xenpci,
and get a pure HVM guest with no PV devices at all.

After removing XENHVM and xenpci - booting a FreeBSD 10.1-p8 AMD64 kernel under XenServer 6.5 gets the output below (first few lines scroll off the console in XenServer).

"
cpuid = 0; apic id = 00
instruction pointer     = 0x20:0xffffffff80d96af9
stack pointer           = 0x28:0xffffffff8191bbe0
frame pointer           = 0x28:0xffffffff8191bbf0
code segment            = base 0x0, limit 0xfffff, type 0x1b
                       = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags        = interrupt enabled, IOPL = 0
current process         = 0 (swapper)
trap number             = 9
panic: general protection fault
cpuid = 0
KDB: strack backtrace:
#0 0xffffffff80946ae0 at kdb_backtrace+0x60
#1 0xffffffff8090bc05 at panic+0x155
#2 0xffffffff80d02aef at trap_fatal+0x38f
#3 0xffffffff80d0274c at trap+0x75c
#4 0xffffffff80ce8432 at calltrap+0x8
#5 0xffffffff80918e1f at tc_init+0x23f
#6 0xffffffff80d967a1 at hv_vmbus_init+0x191
#7 0xffffffff80d9735e at vmbus_bus_init+0x1e
#8 0xffffffff808bad38 at mi_startup+0x108
#9 0xffffffff802d9f0c at btext+0x2c
"


I'll try rebuilding it with debugger support (it's been a while).

Cheers,

-Karl
_______________________________________________
freebsd-xen@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-xen
To unsubscribe, send any mail to "freebsd-xen-unsubscr...@freebsd.org"

Reply via email to