Follow-up Comment #10, patch #1252 (project freeciv):

>> - MAX_UPGRADE_VETERAN_LOSS should be lower. It's certainly
>> a mistake if
>> someone tries to set this to more than 100 veterancy levels
>>  (default ruleset has 5 and IIRC code supports up to 32)

I recalled wrongly. I now checked this and max supported by code is 10. But
of course you should use macro MAX_VET_LEVELS instead of magic 10.

> in civ1 / civ2 rulesets a value of 255 is used (all veterancy
> levels lost?); I now set it to this value ...

civ1 / civ2 rulesets give error messages when loaded because of this. They
should be fixed.

    _______________________________________________________

Reply to this item at:

  <http://gna.org/patch/?1252>

_______________________________________________
  Message sent via/by Gna!
  http://gna.org/


_______________________________________________
Freeciv-dev mailing list
Freeciv-dev@gna.org
https://mail.gna.org/listinfo/freeciv-dev

Reply via email to