Marko Lindqvist writes:
>  I think I can cross-compile new build, but cannot get to Windows
> machine to test it. But co-operation sounds good, if you cannot build
> but can test. :-)

I've used your builds to verify the fix. Details in the ticket.

(FYI, I had no unexpected problems with server or GTK2/SDL clients in
either of your r19844 or r19947 builds -- they all worked fine for me as
far as I pushed them. The Gtk client was perhaps somewhat slower than
Christian's build.)

>  I'd like to get freeciv-modpack icon included to that build so you
> could verify it at the same time.

The icon on the executable appears fine; see attached screenshot.

I couldn't test whether it also works as an icon for the running
application; see next...

> It would be also great if someone
> checks if S2_3 Windows freeciv-modpack works at all. Last time I
> tested S2_3 (a couple of weeks ago), it did launch (but had critical
> bugs since fixed). A couple of days ago I tested TRUNK
> freeciv-modpack.exe and it didn't launch. I'm hoping this is
> trunk-only problem and not something broken in bugfixes that have went
> to both trunk and S2_3.

Afraid not :(
Crashed on launch.
Here's what Windows told me:

Problem signature:
  Problem Event Name:           APPCRASH
  Application Name:             freeciv-modpack.exe
  Application Version:
  Application Timestamp:        4e1e8b12
  Fault Module Name:            msvcrt.dll
  Fault Module Version:         7.0.7600.16385
  Fault Module Timestamp:       4a5bda6f
  Exception Code:               c0000005
  Exception Offset:             000143f9
  OS Version:                   6.1.7601.
  Locale ID:                    2057
  Additional Information 1:     0a9e
  Additional Information 2:     0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:     0a9e
  Additional Information 4:     0a9e372d3b4ad19135b953a78882e789

> In general, at least I have *never* really used freeciv-modpack in
> Windows, and probably nobody else has either (well, considering what
> kind of Windows-specific bugs I have lately fixed in it: nobody could
> have used it) A bit frustrating that it was mainly problems of Windows
> users in installing custom content that inspired whole freeciv-modpack
> and now it's possible (likely even) that we will not have it for
> Windows in 2.3.0.

It would be a shame. Is it possible it's a problem with crosser, and
will work fine in Christian's build? Well, I guess we'll find out...

I also tried the freeciv-modpack.exe from the Sourceforge 2.3.0-beta4
Windows installer; it ran and presented its GUI, but said "Cannot
determine control directory". Presumably this is because of GNA#18262,
and would be fixed in the latest version, if it ran.

I note that the beta4 installer doesn't put freeciv-modpack on the Start
menu along with the server and client; I had to hunt around in the
installation directory for it, which defeats the point somewhat. Would
be nice to fix this for RC1. I think this has to be done by Christian,
as I don't think the installer stuff is under revision control

<<attachment: freeciv-modpack-icon.png>>

Freeciv-dev mailing list

Reply via email to