Hi Eric,

Here's what I tried:

- fdisk /dev/sdb
 -> set partition 1 to FAT12 and bootable

- dd of mbr.bin (from syslinux) to /dev/sdb
  dd if=mbr.bin of=/dev/sdb

- create FAT12 filesystem on sdb1:
  mkdosfs -F 12 /dev/sdb1

- create bootsector using your tool:
  ./sys-freedos.pl --disk=/dev/sdb1
  DOS boot sector for /dev/sdb1 will be created by:
        nasm -o /dev/stdout -dISFAT12  ./bootsecs/boot.asm
  Using FAT12, boot code starts at offset 3e. Extended info: drive 0,
  res. 0, sig. 29, serno 4208-C9C4, name [           ], type [FAT12   ].
  Boot sector successfully updated.

- mount sdb1

- copy kernel.sys and command.com to sdb1

- umount sdb1

- try to boot...

I get the string "FreeDOS" and nothing more :(.

- I also tried using the "--lba" flag with "sys-freedos.pl", but result
  was same.


Rob Urban

You wrote:
> now that you already overwrote things, it is of course okay to use
> fdisk and mkdosfs as you did. The only problem is that you gave the
> wrong --disk argument value to sys-freedos.pl ...
> Try that and check how far you get.
> If you really need a fresh partition table, try the one from
> http://syslinux.zytor.com/
> (Partition table -> file mbr.bin in the syslinux download)

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Freedos-user mailing list

Reply via email to