Two cases,
  1) When I am testing this by manually mounting the nfs share(which is 
/xtra )on the NFS server itself using the following command,
 #mount -vvvv -t nfs4 -o sec=krb5 /home
I get whatever problem I described in previous mail(permission issues). Now 
this could be because here IPA is not managing the user/group permissions 
completely(Correct me if I am wrong in this assumption) and all the problem you 
described happen.
2) When I DO NOT mount manually and instead I try to login as a new user on the 
nfsserver machine,  It creates the home folder for this user on the /home 
partition of nfsserver machine because automount is NOT working and hence there 
is no mounted partition to confuse things. So to be able to test it properly, I 
need to fix the issue in automount and get the case #2 tested and working 
properly with /home automatically mounted from the nfsserver. This is my "ipa 
automountlocation-tofiles default"  output,
/etc/auto.master:/-      /etc/  /etc/auto.share/home   

Is this OK ? Please help.
Thanks and regards,Nidal

--- On Fri, 5/13/11, Adam Young <> wrote:

From: Adam Young <>
Subject: Re: [Freeipa-users] FreeIPA for Linux desktop deployment
To: "nasir nasir" <>
Date: Friday, May 13, 2011, 9:29 AM


    On 05/13/2011 12:13 PM, nasir nasir wrote:

              Thanks indeed!

              I tried your suggestions. 

                -- I can mkdir
                -- When I try to chown, I get the following error

                chown: changing ownership of `nasir': Operation
                    not permitted

              Could you please explain me what do you mean by 'You
                probably need rwx permissions in /etc/export' ? This is
                my /etc/export file,

    see the  '(rw'  in those lines?  That indicates read and write
    privs, but not execute.  


    I'm not an nfs guru, so I might be wrong.  this post suggests that I
    am wrong:  


    SInce IPA is managing the IDs, they should be in sync across the NFS
    and autmounted client machines, but there might be something not
    right in the setup.  if the IPA server isn't managing the machine
    that serves as your NFS server, then the IDs are certainly going to
    be out of sync.






              Also, I have configured a separate client machine
                (RHEL 6.1) and configured it as NFS server (previously
                my NFS server was IPA server itself) and the result is
                same. All the above commands are from this client
                machine only.

              Thanks indeed again!






                                oddjob-mkhomedir[16401]: error
                                    setting permissions on /home/abc:
                                    Operation not permitted

                    It might be a root squash issue.  My guess is that
                    the order of operations for creating a root
                    directory, which is done by root, is:


                    1.  mkdir /home/userid

                    2.  chown uid:gid  /home/userid


                    It sounds from the error message that the first
                    stage happened, but NFS is not allowing the second
                    stage.  To confirm,  as a root (and kinit admin)
                    user on the client machine, just try these two steps
                    in order and see if they still fail.


                    chown is a different system call from mkdir, and
                    might have different nfs enforced permissions.  You
                    probably need rwx permissions in /etc/export.


Freeipa-users mailing list

Reply via email to