Thanks indeed!
I tried your suggestions. 
  -- I can mkdir  -- When I try to chown, I get the following error
chown: changing ownership of `nasir': Operation not permitted
Could you please explain me what do you mean by 'You probably need rwx 
permissions in /etc/export' ? This is my /etc/export file,
/xtra  *(rw,fsid=0,insecure,no_root_squash,no_subtree_check)/xtra  
Also, I have configured a separate client machine (RHEL 6.1) and configured it 
as NFS server (previously my NFS server was IPA server itself) and the result 
is same. All the above commands are from this client machine only.
Thanks indeed again!

                oddjob-mkhomedir[16401]: error setting
                    permissions on /home/abc: Operation not permitted

    It might be a root squash issue.  My guess is that the order of
    operations for creating a root directory, which is done by root, is:


    1.  mkdir /home/userid

    2.  chown uid:gid  /home/userid


    It sounds from the error message that the first stage happened, but
    NFS is not allowing the second stage.  To confirm,  as a root (and
    kinit admin) user on the client machine, just try these two steps in
    order and see if they still fail.


    chown is a different system call from mkdir, and might have
    different nfs enforced permissions.  You probably need rwx
    permissions in /etc/export.
Freeipa-users mailing list

Reply via email to