On Fri, Apr 18, 2014 at 11:47 AM, Saket Choudhary <sake...@gmail.com> wrote:
> On 18 April 2014 14:59, Peter Cock <p.j.a.c...@googlemail.com> wrote:
>> Very strange. Adding "ls test-data" to the TravisCI list worked,
>> and showed the input file condel_input.tabular was present:
>> https://github.com/saketkc/galaxy_tools/commit/c04ff946db0182de9aca4f6dc36ff194404cae05
>> https://s3.amazonaws.com/archive.travis-ci.org/jobs/23239476/log.txt
>> https://s3.amazonaws.com/archive.travis-ci.org/jobs/23239477/log.txt
>>
>> How about replacing that with "ls -l test-data/condel_input.tabular"
>> to verify the ownership and permissions (although if that was
>> the upload problem, Galaxy could give a clearer error).
>>
>
> Thanks, tried it: 
> https://travis-ci.org/saketkc/galaxy_tools/jobs/23270454#L530
>

I see, that looks fine:

$ ls -l test-data/condel_input.tabular
-rwxrwxr-x 1 travis travis 110 Apr 18 10:28 test-data/condel_input.tabular

> This happens irrespective of using ftype. and the plce where ERROR
> occurs is this:
>
> ...
>
> so my dataset state is set to ERROR, essentially upload failed. But
> why, is what it doesn't tell me.

If this were a systematic problem other people should have seen
it - but I have tests using tabular input files which still work fine.

I wonder where exactly in the process it is failing... perhaps in the
metadata processing which would be consistent with it being some
oddity in your sample file which is causing trouble?

Can you upload this file condel_input.tabular into Galaxy via the
UI without error?

Peter
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to