>>>> Carol Spears <[EMAIL PROTECTED]> 14/06/2004 18:14:22 >>>
>> Gtk configure fails at:
>> checking for GLIB version >= 2.4.0... no
>> *** Could not run GLIB test program, checking why...
>> etc...
>> This is SECOND check for GLIB, first check passed!:
>> checking for glib-2.0 >= 2.4.0  atk >= 1.0.1  pango >= 1.4.0... yes
>> the message says it might be finding an old version of Glib, but I do not want to 
>> remove
>> this and damage other installations of GIMP/GTK (I thought it WAS possible to have
>> parallel installations of GTK).
>> Has anyone else experienced this difficulty?  Could anyone suggest a way to install
>we have been seeing this exact problem with debian, fedora, suse.  maybe
>mandrake -- i cannot remember exactly.
>it seems to be a problem with pkg-config and the suggestions of how to
>fix it are many.
>for some reason, there is a glib-2.4 on your computer but there is no
>glib-2.4.pc in the place that pkg-config should be putting one.  in that
>place is a glib-2.3.pc.

I am getting a bit further, but have had to install glib in a 'standard' location
(i.e. under /usr/local) rather than the test area I was using.  The 'pc' file
for glib seems to be glib-2.0.pc by the way, and is OK.

Now when configuring GTK I get further, but it fails with

sh: gnome-config: not found
configure: error: Pango 1.2.0 and Xft backend is required for x11 target

Now, the installation document does say installation of FreeType2 is a prerequisite,
and I've managed to install this.  It also mentions 'PangoFT2', and I am wondering
if this is what is missing.  I have not managed to find a download for this, so I don't
know if its part of another package. 
Could someone help me find 'PangoFT2' ?



This message has been scanned but we cannot guarantee that it and any
attachments are free from viruses or other damaging content: you are
advised to perform your own checks.  Email communications with the
University of Nottingham may be monitored as permitted by UK legislation.

Gimp-user mailing list

Reply via email to