> On Fri, Feb 10, 2006 at 02:27:42PM -0500, Scott wrote:
>> gimp-composite-sse.c: In function
>> 'gimp_composite_scale_rgba8_rgba8_rgba8_sse':
>> gimp-composite-sse.c:786: error: PIC register '%ebx' clobbered in 'asm'
>> make[3]: *** [libcompositesse_a-gimp-composite-sse.o] Error 1
>> make[2]: *** [all-recursive] Error 1
>> make[1]: *** [all-recursive] Error 1
>> make: *** [all] Error 2
>> -----------------------------------------------------
>> I then can seem to run a make install, but there is no gimp executable.
>> Only gimp-remote seems to get installed. Can someone perhaps lead me in
>> the right direction with this?
> recently there was the same problem with mmx.  if you run ./configure
> --help it will tell you how to build without this sse stuff.  these are
> some "optimizations" that were included by some guy from Sun and seem to
> be unmaintained lately.

I ran it with --disable-mmx, now ld does not support the -rpath switch on
OS X. And there does not seem to be an option to disable it in the
configure, at least that I found .

> if you are using apple products, you probably are not interested in
> speed so probably building without that stuff will not seem to hurt
> performance.

I use to think that, I am an avid Linux and Solaris user. But, OS X is
much further along in regards of ease of use and application support for
my family members. This allows me to insure there will never be any
microsoft products in my house. :-)

But this Imac is the 2.0 DC w/1gb of RAM. Under normal usage it runs
nicely, it does seem to stumble sooner under high load then my Sun Ultra
20 (opteron) does. But, generally speaking it is a good performer..

Thanks for all your help..


Gimp-user mailing list

Reply via email to