Hi,

glib and gtk-related .pc files are in /usr/lib/pkgconfig. In
/usr/local/lib/pkgconfig I have babl.pc, gegl.pc, gio-2.0.pc,
gio-unix-2.0.pc, glib-2.0.pc but no gtk.pc, probably because it is not
installed yet?

I ran
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
export PKG_CONFIG_PATH
and still I have this damned eroor on 'make':

libtool: link: gcc -DGDK_PIXBUF_DISABLE_DEPRECATED -g -O2 -Wall -o
.libs/gtk-query-immodules-2.0 queryimmodules.o
./.libs/libgtk-x11-2.0.so -L/usr/local/lib
/home/julien/telechar/gtk+-2.16.5/gdk/.libs/libgdk-x11-2.0.so
/usr/lib/libatk-1.0.so /usr/lib/libgobject-2.0.so
/usr/lib/libgmodule-2.0.so /usr/lib/libglib-2.0.so -lpcre -lpangoft2-1.0
../gdk-pixbuf/.libs/libgdk_pixbuf-2.0.so ../gdk/.libs/libgdk-x11-2.0.so
-lpangocairo-1.0 -lpango-1.0 /usr/lib/libXinerama.so
/usr/lib/libXcursor.so /usr/lib/libXcomposite.so /usr/lib/libXext.so
/usr/lib/libXdamage.so /usr/lib/libXfixes.so /usr/lib/libcairo.so
/usr/lib/libfontconfig.so /usr/lib/libfreetype.so -lexpat
/usr/lib/libglitz.so /usr/lib/libpng12.so -lz
/usr/lib/libxcb-render-util.so /usr/lib/libxcb-render.so
/usr/lib/libXrender.so /usr/lib/libpixman-1.so /usr/lib/libX11.so
/usr/lib/libxcb-xlib.so /usr/lib/libxcb.so -lXau
/home/.../telechar/gtk+-2.16.5/gdk-pixbuf/.libs/libgdk_pixbuf-2.0.so
/usr/local/lib/libgio-2.0.so /usr/local/lib/libgobject-2.0.so
/usr/local/lib/libgmodule-2.0.so -ldl /usr/local/lib/libglib-2.0.so -lm
./.libs/libgtk-x11-2.0.so: undefined reference to
`g_signal_chain_from_overridden_handler'
/usr/local/lib/libgio-2.0.so: undefined reference to `g_poll'
./.libs/libgtk-x11-2.0.so: undefined reference to
`g_signal_override_class_handler'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_dpgettext2'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_set_error_literal'
./.libs/libgtk-x11-2.0.so: undefined reference to
`g_signal_new_class_handler'
./.libs/libgtk-x11-2.0.so: undefined reference to `g_dgettext'
collect2: ld returned 1 exit status
make[4]: *** [gtk-query-immodules-2.0] Error 1

The problem doesn't seem to be in pkgconfig or glib. What are these
"undefined reference"?



Doug a écrit :
> 
> PKG_CONFIG_PATH needs to point to a pkconfig folder containing various
> .pc files.
> 
> Look in /usr/lib/pkconfig and /usr/local/lib/pkconfig and check where
> various glib- and gtk-related .pc files are located.
> You may well need both pkconfig folders.
> Then
> PKG_CONFIG_PATH=/usr/local/lib/pkconfig:/usr/lib/pkconfig; export
> PKG_CONFIG_PATH; ./configure
> 
> You should be able to compile but you may not be able to run, because
> the program can't find this or that library which you know you have -
> you get a message saying "couldn't find library lib......so....."
> 
> Setting LD_LIBRARY_PATH may avoid that happening, but quite often it
> doesn't.
> Usually it's because the program insists on looking for that library in
> /usr/lib when you've got it in /usr/ local (or /usr/lib64 on a 64-bit
> machine).
> In that case, as root create absolute links from /usr/lib to all those
> particular library lib......so... files in /usr/local/lib (or wherever).
> It solves most problems.
> 
> HTH
> 
> Doug
> 
> 
> 
> 
> julien wrote:
>> Hi,
>>
>> I had installed glib-2.20.4 through a rpm built with checkinstall. I
>> uninstalled it and re-installed glib with "make install".
>>
>> I have the  glib-2.0 directory in /usr/share, /usr/local/share,
>> /usr/local/lib
>>
>> The PKG-CONFIG_PATH and LD_LIBRARY_PATH environment variables are empty.
>>
>> I tried "export LD_LIBRARY_PATH='/usr/local/lib' && export
>> PKG_CONFIG_PATH='/usr/local/lib' " before ./configure in the gtk+-2.16.5
>> directory : my problem persits.
>>
>> I also added the three glib-2.0 paths in ld.so.conf, without any success.
>>
>> Is this actually a glib path problem? I have the
>> /usr/local/lib/libgio-2.0.so file...
>>
>>  
>>> On 08/01/2009 08:44 PM, julien wrote:
>>>    
>>>> Hi,
>>>>
>>>> I am trying to install gtk+-2.16.5 from sources under openSuse-11.0,
>>>> (before installing unstable GIMP for UI translation).
>>>> "Configure" gives no error message.
>>>> Running "make" gives this error:
>>>>
>>>> /usr/local/lib/libgio-2.0.so: undefined reference to `g_poll'
>>>>
>>>> I can't find how to resolve this problem.
>>>> I'd be grateful for any help.
>>>>       
>>> Looks like you're not linking against the proper GLib library, make sure
>>> to setup PKG_CONFIG_PATH and LD_LIBRARY_PATH at configure time so that
>>> the right dependencies are found preferably through the use of
>>> config.site.
>>>
>>>  / Martin
>>>     
> 
> 




_______________________________________________
Gimp-user mailing list
Gimp-user@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-user

Reply via email to