Since this is ALL so confusing for me, I will write each question here and 
answer them.

Ofnuts :
Question :
1) check that you have files in your {gimp installation 
directory}/2.0/plug-ins/ and {gimp installation directory}/2.0/scripts/ 
directories (in Linux they are in /usr/lib/gimp and /usr/share/gimp 
respectively, in Windows, somewhere under c:\Program Files\gimp) 
(likely, otherwise you wouldn't be able to load/saves files). You should 
have about 200 files in the plugins directory.

2) erase the pluginrc and menurc files in your .gimp-2.6 directory 
(~/.gimp-2.6/pluginrc in Linux, c:\Documents en 
Settings\{your_id}\.gimp-2.6\pluginrc in WinXP and somewhere equivalent 
in Vista/W7) and restart Gimp, they should be rebuilt. In a normal gimp 
installation, pluginrc is several thousands lines and lists close to 200 
plugins, menurc is around a thousand lines.

Answer :
This is EXACTLY what I did : 
1) I re-installed it. 
2) Took out "ko" from locale. 
3) From my user, I scrolled down, and deleted Menurc, and pluginrc. 
4) Started Gimp 2, and kept x-ing out the plug-in error. 
5) Checked, Still the same 3 choices.

You may just need to change image mode to RGB Image/Mode select RGB.

Answer :
Checked. RGB Image. But thanks for the help~!~ 

Matthew Green :
Question :
When you start GIMP for the first time, with a blank / empty image - are the 
filter options still gone?

Answer :
Yup, Matthew. Three choices only.. 

M@tthew Green :
Question :
Are you running Windows, or something else?

Answer :
Windows, Matthew. 

Ofnuts :
Question :
 4) Started Gimp 2, and kept x-ing out the plug-in error. 
What does that mean? What error? Any message? What does it say?

Answer :
This is one of the errors : 
The prograam can't start because libgimppui-2.0-0.dll is 
missing from your computer. Try reinstalling the program 
to fix this program.

and so much more o_o 

Ofnuts :
Question :
So let's fix this first... did you reinstall as recommended? Can you 
open a command prompt, and do:

dir "c:Program Files\Gimp2.6" /s >gimpinstall.txt

and paste the results here (replace "c:Program Files\Gimp2.6" by 
whatever directory Gimp has been installed in)

Answer :
Well it said : 
dir "c:Program Files (86x)\.gimp-2.6" /s >gimpinstall.txt 
The system cannot find the file specified.

(Sorry for the long reply...) 

Mike Williams :
Question :
Try it again without the dot in front of gimp and with a slash after c:

dir "c:\Program Files (86x)\gimp-2.6" /s >gimpinstall.txt

That is, if your program files directory actually include (86x).

If you get the same result, here is something else to try.

At the dos prompt, type "c:\program 
then hit the tab key. It should fill in the rest of the program files 
directory. The directory name will be followed by double quotes, press the 
backspace key once to remove the "

Then type: \gimp

and hit the tab key again. It should fill in the rest of the gimp directory 

Then type the closing quote and add /s >gimpinstall.txt

Your determination is impressive. Keep it up, you'll get there.

Answer :
Thank you for the support. 
I am on my other computer, and downloaded Gimp here, and the filters work 
I will try that when I'm on my other computer. 
Thank you SO MUCH for helping! 
Also, same to the others who are helping me so much! 
** I did the wrong directory. **

Kevin Brubeck Unhammer :
Question :
Not ".gimp-2.6", but "Gimp2.6". They are asking for what files are 
within the program directory (not your settings/plugins directory).

hope this helps,

Answer :
I did the that part wrong, so I fixed it but same answer. 
Thank you :)

Ofnuts :
Wrong directory. name ... .gimp-2.6 is a directory in your user file 
space where Gimp keeps your own settings. The directory I'm talking 
about must be called Gimp-2.0 (if my memory is good) without leading 
dot. It should be easy to spot with the file explorer.


Jenette (via
Gimp-user mailing list

Reply via email to