On Mon 16.11.2009 08:52, Willy Tarreau wrote:

On Sun, Nov 15, 2009 at 10:28:21PM +0100, Aleksandar Lazic wrote:
Hi Cyril,

On Fre 13.11.2009 22:50, Cyril Bonté wrote:
>Hello Willy,


>First I added it as I did for "request-learn" but shouldn't it be
>better to define these options more "haproxy like" (using "option" and
>"no option") ?
>Which would give :
>(no) option appsession-request-learn
>(no) option appsession-capture-cookie



What you can do however is to create a new prefix keyword like we have
for "timeout" or "tcp-request" and put the flags somewhere
else. "appsession" would have been fine but it's already used.  Maybe
you can use "appcookie" ? Something like this :

  appcookie request-learn
  appcookie capture

Both are ok for me.
My point of view is to be able to explain and handle it straight
For me both looks ok, mybe we use

app-op (=> for abbreviation ;-) )

Due to the fact that not only the cookie is relevant for the application

How about to add also a

app* delimiterstart (default ;)
app* delimiterstop  (defautl =)

in combination with the length you get the maximum flexibility for this
module ;-)



Reply via email to