From: Ville Syrjälä <[email protected]>
Fix up some bugs around the cdclk pcode notificatiosn on DG2,
follow up with some unification/cleanups, and finally convert
the pcode stuff (except on dg2, due to it doing weird things)
into vfuncs (goal being to make the code less messy).
Ville Syrjälä (14):
drm/i915/cdclk: Don't bail if pcode post nofify fails
drm/i915/cdclk: Pass CDCLK in MHz to pcode on DG2
drm/i915/cdclk: Do the DG2 CDCLK/pipe power well notify properly
drm/i915/cdclk: Notify DG2 pcode about pipe power wells regardless of
CDCLK
drm/i915/cdclk: Stop forcing voltage level to 3 all the time on DG2
drm/i915/cdclk: Drop pointless platform check from bxt_set_cdclk()
drm/i915/dg2: s/intel_/dg2_/ for DG2 specific stuff
drm/i915/cdclk: Unify the pcode pre/post notify in bxt_set_cdclk()
drm/i915/cdclk: Unify pcode related debugs
drm/i915/cdclk: Extract bdw_cdclk_pcode_{pre,post}_notify()
drm/i915/cdclk: Extract skl_cdclk_pcode_{pre,post}_notify()
drm/i915/cdclk: Extract bxt_cdclk_pcode_{pre,post}_notify()
drm/i915/cdclk: Introduce CDCLK .{pre,post}_notify() vfuncs
drm/i915/cdclk: Hoist intel_cdclk_{pre,post}_notify() calls upwards
drivers/gpu/drm/i915/display/intel_cdclk.c | 301 ++++++++++++---------
1 file changed, 171 insertions(+), 130 deletions(-)
--
2.53.0