Hi, > > IMHO there is only one thing to concider and that has to do with the > > name of the two files and there relation. I did not follow the > > 'release thread' that close (sorry) and when I saw a 'jallib' and a > > 'devices' file, I assumed I need both. Maybe when the the second was > > named 'all_devices', I'd have an other assumption. In the > > announcement, it should be stated that you need to get the first one > > and only if your chip is not in there, you should get the second one > > (and let us know). > > I support that.
Which ? Renaming to "jallib-all_devices" or tell users the differences ? Or both ? > > And issue's for the real release: > > - adc_hardware.jal could be renamed to adc.jal (There won't be any adc > > without hardware). > > - the example with comment within comment is not properly converted to > > the html (maybe because it is not properly formatted). > > - last call: let's rename delay_any_mc.jal to delay.jal (it's a much > > better name and if we don't do it now, any_mc will be there for ever). > Seems a good idea to me too. OK, I don't like these last minute changes, but I'll change this in unvalidated and copy the modified files to validated (for adc and delay). I've also noted there's no "pragma deprecated", which could be nice when API changes. Maybe another feature request for Kyle ? About html, I think jalapi might be too ambitious: the formatting problem is because ascii code is parsed just like in the google code wiki. Thus you can have real html bullet list, tables, etc... That seems not a good idea in practical life, but formatting to be nice looking in the source file can produce nasty html. I'll remove this and put a <pre> tag, so ascii formatting is kepts in html page. I plan to do this for the final relase, *not* for this beta. > Now some remarks of my own... ;-) > > The <jallib...>/sample/test directory has subdirectories but none of > those have a single file. Should the test library be part of the > distribution? I think not. Removed. > The file 'chipdef_jallib.jal' is missing from <jallib...>/lib > Pretty essential to compile any program! Ah... Indeed :) > BTW I fixed another typo in the test table: 16f54.jal/b16f57.jal My script worked on the first name, so the blink file was ok. You can check, just to be sure. These typos won't exist anymore when using the testing matrix and jallib wrapper. Cheers, Seb -- Sébastien LELONG http://www.sirloon.net http://sirbot.org --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "jallib" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [EMAIL PROTECTED] For more options, visit this group at http://groups.google.com/group/jallib?hl=en -~----------~----~----~----~------~----~------~--~---
