Sebastien LELONG wrote:
[Joep
>>> IMHO there is only one thing to concider and that has to do with the
>>> name of the two files and there relation. I did not follow the
>>> 'release thread' that close (sorry) and when I saw a 'jallib' and a
>>> 'devices' file, I assumed I need both. Maybe when the the second was
>>> named 'all_devices', I'd have an other assumption. In the
>>> announcement, it should be stated that you need to get the first one
>>> and only if your chip is not in there, you should get the second one
>>> (and let us know).
>> I support that.
>
> Which ? Renaming to "jallib-all_devices" or tell users the differences ? Or
> both ?
To avoid confusion with users they should be informed one way or the
other about the differences between the 2 packages. Renaming the second
to 'all_devices' is an improvement, but maybe not enough. I think it is
good also to explain why not all device files are in the first package.
BTW <base> and <extended> of <complete> might be other possible
qualifications.
>
>>> And issue's for the real release:
>>> - adc_hardware.jal could be renamed to adc.jal (There won't be any adc
>>> without hardware).
>>> - the example with comment within comment is not properly converted to
>>> the html (maybe because it is not properly formatted).
>>> - last call: let's rename delay_any_mc.jal to delay.jal (it's a much
>>> better name and if we don't do it now, any_mc will be there for ever).
>
>> Seems a good idea to me too.
>
> OK, I don't like these last minute changes,
After sending my msg I realized that also samples would need to be
changed. But changing with the next release might be worse for the users
than a possible typo in the samples with this beta.
>
>> BTW I fixed another typo in the test table: 16f54.jal/b16f57.jal
>
> My script worked on the first name, so the blink file was ok. You can check,
> just to be sure. These typos won't exist anymore when using the testing
> matrix and jallib wrapper.
The error was in the first name (name of the device file), and the
package did not contain the 16F57 sample.
(This chip needs special wiring, it's pinout doesn't resemble any other
28 pins PDIP PIC. So it would be wasted test time if it missed the
release).
Regards, Rob.
--
Rob Hamerling, Vianen, NL (http://www.robh.nl/)
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups
"jallib" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at
http://groups.google.com/group/jallib?hl=en
-~----------~----~----~----~------~----~------~--~---