> To avoid confusion with users they should be informed one way or the > other about the differences between the 2 packages. Renaming the second > to 'all_devices' is an improvement, but maybe not enough. I think it is > good also to explain why not all device files are in the first package.
OK, I'll do both. > BTW <base> and <extended> of <complete> might be other possible > qualifications. I personally don't like these, because: * "jallib" package isn't a base package. * "jallib" with all device files (whatever the name) extends "only" the device part (so it should be explicit in the name, thus the "jallib-all_devices" * "jallib" with all devices files is not complete either, because it lacks all other libs. Let's try "jallib" and "jallib-all_device" + mention the differences, and we'll see if we need to refine this. > >>> And issue's for the real release: > >>> - adc_hardware.jal could be renamed to adc.jal (There won't be any adc > >>> without hardware). > >>> - the example with comment within comment is not properly converted to > >>> the html (maybe because it is not properly formatted). > >>> - last call: let's rename delay_any_mc.jal to delay.jal (it's a much > >>> better name and if we don't do it now, any_mc will be there for ever). > >> > >> Seems a good idea to me too. > > > > OK, I don't like these last minute changes, > > After sending my msg I realized that also samples would need to be > changed. But changing with the next release might be worse for the users > than a possible typo in the samples with this beta. I'm on it, at least for "unvalidated" map. We need to decice if we put these modifs on validated, thus the release. That said, I've seen some nasty compilation errors (see my previous posts), so maybe we should postpone the beta, just to be sure. I'm trying scripting validating things as much as I can, but we'd all need to test. So, including a "delay" and an "adc" lib might not be impossible IMHO. Seb -- Sébastien LELONG http://www.sirloon.net http://sirbot.org --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "jallib" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [EMAIL PROTECTED] For more options, visit this group at http://groups.google.com/group/jallib?hl=en -~----------~----~----~----~------~----~------~--~---
