sitter added inline comments.


> aacid wrote in klanguagename.cpp:30
> should the second param be code too?
> I mean if we read the docs we say both are code (ISO 639-1), so both should 
> be the same and not only the first part?

Do you mean both being **a** code or both being **the** code?

a code

`` is the code of the current locale. The only way I found to get 
the 639 code from qlocale is by splitting name

Perhaps a comment is needed to explain this?

the code

Both params being the variable `code` wouldn't be right I think. The 
documentation for `nameForCode` says it will ideally give you the localized 
name of code in the system language.

  LANGUAGE=en nameForCode('en') => 'English'
  LANGUAGE=fr nameForCode('en') => 'anglaise'

which internally is

  nameForCodeInLocale('en', 'en')
  nameForCodeInLocale('en', 'fr')

  R265 KConfigWidgets


To: aacid
Cc: hein, kde-frameworks-devel, sitter, markg, apol, michaelh, ngraham, bruns

Reply via email to