On 2007-07-13T13:39:12, David Lee <[EMAIL PROTECTED]> wrote:
> I've recently had a look inside "ping.c" and "ping_group.c". It wasn't a
> great surprise to find some commonality. I guess one was derived from
> other. It means that we've got considerable code duplication, potential
> unnecessary divergence and potential "one-but-miss-the-other" bugfixes).
>
> Might it be worth attempting to merge them into a more-or-less common
> codebase? If you think this is worth investigating, then it's probably
> something I could look at, low priority, in the coming months.
I think it'd be even better to move the ping functionality into pingd
itself, instead of handling it at the membership level, where it
needlessly increases complexity.
Regards,
Lars
--
Teamlead Kernel, SuSE Labs, Research and Development
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)
"Experience is the name everyone gives to their mistakes." -- Oscar Wilde
_______________________________________________________
Linux-HA-Dev: [email protected]
http://lists.linux-ha.org/mailman/listinfo/linux-ha-dev
Home Page: http://linux-ha.org/