David Lee wrote: > I've recently had a look inside "ping.c" and "ping_group.c". It wasn't a > great surprise to find some commonality. I guess one was derived from > other. It means that we've got considerable code duplication, potential > unnecessary divergence and potential "one-but-miss-the-other" bugfixes).
I just put an identical bug fix into both. So, I know what you're talking about... > Might it be worth attempting to merge them into a more-or-less common > codebase? If you think this is worth investigating, then it's probably > something I could look at, low priority, in the coming months. I think this would be worth looking at. Perhaps some ping functions in the clplumbing library? But, you know what would be even more interesting, before doing that? Write a quorum module which used the ping information that heartbeat collects to declare whether we had quorum or not. This is why I wrote the ping code in the first place - that and the fact that it was incredibly simple to do here ;-) In the meantime, Kevin found a good use for it, which Andrew replicated. Here's the bugzilla for that capability: http://old.linux-foundation.org/developer_bugzilla/show_bug.cgi?id=1497 This would greatly improve the situation for 2-node clusters and in most cases would eliminate the possibility of mutual-STONITH. This should be pretty simple to implement, and it would be totally awesome! -- Alan Robertson <[EMAIL PROTECTED]> "Openness is the foundation and preservative of friendship... Let me claim from you at all times your undisguised opinions." - William Wilberforce _______________________________________________________ Linux-HA-Dev: [email protected] http://lists.linux-ha.org/mailman/listinfo/linux-ha-dev Home Page: http://linux-ha.org/
